aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 18 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 6b8c682..1bc3a17 100644
--- a/setup.py
+++ b/setup.py
@@ -1,12 +1,27 @@
1from setuptools import setup 1from setuptools import setup
2 2
3test_deps = ['pytest', 'pytest-runner', 'pytest-cov', 'vcrpy', 'pytest-vcr', 'pytest-mock', 'requests-mock'] 3test_deps = [
4 'pytest',
5 'pytest-runner',
6 'pytest-cov',
7 'vcrpy',
8 'pytest-vcr',
9 'pytest-mock',
10 'requests-mock'
11]
12
13webpush_deps = [
14 'http_ece>=1.0.5',
15 'cryptography>=1.6.0',
16]
17
4extras = { 18extras = {
5 "test": test_deps 19 "test": test_deps,
20 "webpush": webpush_deps,
6} 21}
7 22
8setup(name='Mastodon.py', 23setup(name='Mastodon.py',
9 version='1.4.2', 24 version='1.4.3',
10 description='Python wrapper for the Mastodon API', 25 description='Python wrapper for the Mastodon API',
11 packages=['mastodon'], 26 packages=['mastodon'],
12 install_requires=[ 27 install_requires=[
@@ -16,8 +31,6 @@ setup(name='Mastodon.py',
16 'pytz', 31 'pytz',
17 'python-magic', 32 'python-magic',
18 'decorator>=4.0.0', 33 'decorator>=4.0.0',
19 'http_ece>=1.0.5',
20 'cryptography>=1.6.0',
21 'blurhash>=1.1.3', 34 'blurhash>=1.1.3',
22 ], 35 ],
23 tests_require=test_deps, 36 tests_require=test_deps,
Powered by cgit v1.2.3 (git 2.41.0)