aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLorenz Diener <[email protected]>2016-11-24 20:40:23 +0100
committerLorenz Diener <[email protected]>2016-11-24 20:40:23 +0100
commitcc1bae06c2354b2155a4bb7f2971e40f8b783dc8 (patch)
tree84485022ff187d5feb9a28d608da444fec72dfac /setup.py
parentd6bbd27153241b74d2f08be48b3efaccd6c0b7dd (diff)
downloadmastodon.py-cc1bae06c2354b2155a4bb7f2971e40f8b783dc8.tar.gz
Preparation for pypi packaging
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py17
1 files changed, 16 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 4b5b11f..6a4df40 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,21 @@
1from setuptools import setup, find_packages 1from setuptools import setup, find_packages
2 2
3setup(name='Mastodon.py', 3setup(name='Mastodon.py',
4 version='1.0.0',
4 description='Python wrapper for the Mastodon API', 5 description='Python wrapper for the Mastodon API',
5 packages=['mastodon'], 6 packages=['mastodon'],
6 install_requires=['requests']) 7 install_requires=['requests'],
8 url='https://github.com/halcy/Mastodon.py',
9 author='Lorenz Diener',
10 author_email='[email protected]',
11 license='MIT',
12 keywords='mastodon api microblogging',
13 classifiers=[
14 'Development Status :: 4 - Beta',
15 'Intended Audience :: Developers',
16 'Topic :: Communications',
17 'License :: OSI Approved :: MIT License',
18 'Programming Language :: Python :: 2',
19 'Programming Language :: Python :: 3',
20 ]
21)
Powered by cgit v1.2.3 (git 2.41.0)