aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcodl <[email protected]>2017-11-28 06:03:13 +0100
committercodl <[email protected]>2017-11-28 06:03:13 +0100
commit95777fe58e2c61640e377f447594b9c4f4f91542 (patch)
tree57231a5f979ac4abee7ca9a29d15131475b36da4 /setup.py
parentd47f915bfb81b5be1d980bf0258bbdd7fe75e16d (diff)
downloadmastodon.py-95777fe58e2c61640e377f447594b9c4f4f91542.tar.gz
add [test] extra so test deps can be installed before running tests
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 7 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index d2ab253..5a9d8cc 100644
--- a/setup.py
+++ b/setup.py
@@ -1,12 +1,18 @@
1from setuptools import setup 1from setuptools import setup
2 2
3test_deps = ['pytest', 'pytest-cov', 'vcrpy', 'pytest-vcr', 'pytest-mock']
4extras = {
5 "test": test_deps
6}
7
3setup(name='Mastodon.py', 8setup(name='Mastodon.py',
4 version='1.1.2', 9 version='1.1.2',
5 description='Python wrapper for the Mastodon API', 10 description='Python wrapper for the Mastodon API',
6 packages=['mastodon'], 11 packages=['mastodon'],
7 setup_requires=['pytest-runner'], 12 setup_requires=['pytest-runner'],
8 tests_require=['pytest', 'pytest-cov', 'vcrpy', 'pytest-vcr', 'pytest-mock'],
9 install_requires=['requests', 'python-dateutil', 'six', 'pytz'], 13 install_requires=['requests', 'python-dateutil', 'six', 'pytz'],
14 tests_require=test_deps,
15 extras_require=extras,
10 url='https://github.com/halcy/Mastodon.py', 16 url='https://github.com/halcy/Mastodon.py',
11 author='Lorenz Diener', 17 author='Lorenz Diener',
12 author_email='[email protected]', 18 author_email='[email protected]',
Powered by cgit v1.2.3 (git 2.41.0)